Open In App

Configuring RIP Route Metric Offset-Lists in Cisco

Last Updated : 26 Nov, 2022
Improve
Improve
Like Article
Like
Save
Share
Report

RIP stands for Routing Information Protocol which is a Distance Vector Routing Protocol (one of the types of Dynamic Routing Protocol). It is a DVRP that relies on the hop count as its metric to calculate the best path to the destination. It uses UDP (User Datagram Protocol) as its Transport Layer Protocol with port 520.

A metric is a value assigned to an IP route that generally tells the path cost of reaching that particular network through a particular interface. It can be calculated in terms of link speed, hop counts, or time delay.

RIP uses hop counts as its metric value, i.e., the number of networks or routers the frame has to cross in order to reach the destination network. RIP allows a range of metrics from 1 to 16, where the last legitimate and accepted value is 15 (max value of metric in RIP). It uses 16 as a metric value to advertising the routes that are no longer available in the router’s routing table and are inaccessible (infinite path cost). This process of advertising routes having a metric value of 16 is also known as Route Poisoning. 

Offset-Lists:

  • An offset list is a method that is used to change the metric value of a particular route either when it is received on an interface through a Dynamic Routing Protocol (like EIGRP or RIP) or when it is being sent out through an interface as an advertisement for a Dynamic Routing Protocol (EIGRP or RIP). These offset lists can only increase the metric value by a manually configured offset value. Offset lists require Access-Lists (ACLs) to match a particular network whose metric is to be increased.
  • Offset lists are used if we have more than one path for a particular destination having the same AD and Metric values. In that case, equal cost load balancing is done, and the traffic is sent equally through all the routes. Therefore, to make the traffic use a single route, we can match that particular route using ACL and increase the metric of the other paths which we want to use as a backup using offset lists.
router(config)#ip access-list standard <name_of_ACL>
router(config-std-nacl)#permit <network_IP> <wildcard_mask>
router(config-std-nacl)#exit
router(config)#router rip
router(config-router)#offset-list <name_of_ACL> <in|out> <offset_value> <interface_id>    

Topology:

Topology

 

Configuring the IP addresses:

On R1: 

R1(config)#int f0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
Configuring the IP addresses on R1

 

On R2: 

R2(config)#int f0/0
R2(config-if)#ip add 10.1.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int f1/0
R2(config-if)#ip add 20.1.1.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
Configuring the IP addresses on R2

 

On R3: 

R3(config)#int f0/0
R3(config-if)#ip add 20.1.1.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int loopback 1

R3(config-if)#ip add 1.1.1.1 255.255.255.255
R3(config-if)#exit
Configuring the IP addresses on R3

 

Configuring RIP on all Routers:

On R1

R1(config)#router rip
R1(config-router)#network 10.1.1.0
R1(config-router)#exit
Configuring RIP on R1

 

On R2: 

R2(config)#router rip
R2(config-router)#network 10.1.1.0
R2(config-router)#network 20.1.1.0
R2(config-router)#exit
Configuring RIP on R2

 

On R3: 

R3(config)#router rip                   
R3(config-router)#network 20.1.1.0 
R3(config-router)#network 1.1.1.1
R3(config-router)#exit
Configuring RIP on R3

 

Verifying Propagation of all the networks on all the Routers:

R1#show ip route
Verifying Propagation on R1

 

R2#show ip route
Verifying Propagation on R2

 

R3#show ip route
Verifying Propagation on R3

 

As it is clear that all the routers have all the networks and their respective routes present in their routing table. In R1’s routing table, it has the route to loopback address 1.1.1.1 of R3 via 10.1.1.2 present at R2’s interface. This route shows the AD value of 120 that is RIP specific and a metric of 2 which means the frame needs to cross two networks or two routers in order to reach the network, i.e., R2 and R3 in this case. Now, we will be applying the offset-list to this route to increase its metric.

Note: Here we are using RIP version 1, therefore the routes advertised are classful and thus the subnet mask present in the routing table is /8 (because the IP address/network belongs to class A of IP addresses).

Configure Offset-list on R1:

R1(config)#ip access-list standard offset_list
R1(config-std-nacl)#permit 1.0.0.0 0.255.255.255
R1(config-std-nacl)#exit
R1(config)#router rip
R1(config-router)#offset-list offset_list in 5 f0/0
R1(config-router)#exit
Configuring Offset-list on R1

 

Verifying the Effect of Offset-List in the Metric:

R1#show ip route
Verifying the Effect of Offset-List on R1

 

As you can see, the metric of the route for R3’s loopback address has now changed from 2 to 7 as we have increased the metric by an offset value of 5 specified in our offset list.


Like Article
Suggest improvement
Share your thoughts in the comments

Similar Reads