Open In App

Configuring RIP Triggered Updates in Cisco

Last Updated : 26 Nov, 2022
Improve
Improve
Like Article
Like
Save
Share
Report

RIP (Routing Information Protocol) is a Distance Vector Routing Protocol (DVRP) which generally uses hop counts to find the best path to the destination.  By RIP, we will be talking about the RIPv2 by default. Since RIPv2 is a dynamic routing protocol:

  • RIPv2 exchanges routes/networks by sending RIP updates on each RIP enabled interface. A RIP enabled router advertises its connected routes as well as the learned routes that are present in its routing table. 
  • RIPv2 does not form neighbor ships, nor does it use any hello packets. Each router just simple sends the updates (Full/Periodic updates or Partial/Triggered updates) to a multicast address of 224.0.0.9.
  • RIPv2 uses a hop-count metric, i.e., counting the number of routers that are needed to be crossed in order to reach the destination network. It allows at most 15 hop counts and 16 is considered to be infinity (inaccessible).

Types of Updates in RIPv2: 

  • Periodic Updates: By default, a RIP enabled router send updates after a regular time interval of 30 seconds. This interval is known as update interval. These Full updates carry all the routing information and are sent after every update interval carrying all the information again and again. This is usually not necessary.
  • Triggered Updates: These updates are sent only when there is a change in the routing information. These updates are the Partial Updates and only carry the changed network information in the update. The change in the routing information can be any of the following: 
    • Connecting or learning about a new network.
    • Disconnecting from a network or learning about it’s not reachability.
    • Change in metric of a connected network.

Topology:

Topology

 

Configuring the IP addresses:

On R1:

R1(config)#int f0/0                     
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int f1/0                     
R1(config-if)#ip add 20.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
Configuring the IP addresses on R1

 

On R2:

R2(config)#int f0/0                     
R2(config-if)#ip add 10.1.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int f1/0                     
R2(config-if)#ip add 192.168.1.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
Configuring the IP addresses on R2

 

On R3:

R2(config)#int f0/0                     
R2(config-if)#ip add 10.1.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int f1/0                     
R2(config-if)#ip add 192.168.1.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
Configuring the IP addresses on R3

 

On PC1:

PC1> ip 192.168.1.2/24 192.168.1.1
Configuring the IP addresses on PC1

 

On PC2:

PC2> ip 192.168.2.2/24 192.168.2.1
Configuring the IP addresses on PC2

 

Configuring RIPv2:

On R1:

R1(config)#router rip
R1(config-router)#version 2       
R1(config-router)#network 10.1.1.0
R1(config-router)#network 20.1.1.0
R1(config-router)#exit
Configuring RIPv2 on R1

 

On R2:

R1(config)#router rip
R1(config-router)#version 2       
R1(config-router)#network 192.168.1.0
R1(config-router)#network 10.1.1.0
R1(config-router)#exit
Configuring RIPv2 on R2

 

On R3:

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 192.168.2.0
R1(config-router)#network 20.1.1.0
R1(config-router)#exit
Configuring RIPv2 on R3

 

Verifying propagation of Routes and Update Message:

  • Checking R1’s routing table to see if it has the networks of the PCs.
R1#show ip route
Verifying propagation of Routes and Update Message on R1

 

As you can see, R1 has the entry for the networks which shows R, i.e., learned via RIP and has AD value of 120 with metric as 1 which means the network is just 1 hop away.

  • Debugging the events of RIP to check the sent and received updates at R1.
R1#debug ip rip events
RIP event verifying on R1

 

As you can see in the debugged events, Router R1 sends update through both the RIP enabled interfaces with the connected routes and is also receiving updates on both the interfaces that are being sent from R2 and R3 with their connected networks. Also, you can see the time-frame after the router R1 resends the update with the connected routes that is almost 30 seconds (update interval).

Verifying Triggered Updates:

  • enabling debugging of RIP to check the flow of updates sent and received on R1.
R1#debug ip rip
  • shutdown the interface of R2 connected to PC1, this will delete the entry of that network from R2’s routing table resulting in change required to send a partial triggered update. And then, no shutdown of the interface to see the change.

Verifying Triggered Updates on R2

 

Verifying Triggered Updates on R1

 

Notice the time-frame of shutting down the interface on R2 and the triggered update received on R1 which says the network is now reachable in 16 hops, i.e., it is now inaccessible.

Verifying Triggered Updates

 

And now, when the interface is back in up state R1 again receives a triggered update in which the network is reachable in 1 hop.

Note: RIPv2 allows triggered updates along with periodic updates by default on all port groups. But if you want to allow only triggered updates, then you must have a point-to-point link connectivity between routers and run the interface-level command ip rip triggered to enable triggered extensions, which enable the interface to only send triggered updates based on the following condition:

  • When the router receives a specific request for a routing update, which causes the full database to be sent.
  • When the information from another interface modifies the routing database, which causes only the latest changes to be sent.
  • When the interface comes up or goes down, which causes a partial database to be sent.
  • When the router is powered on for the first time to ensure that at least one update is sent, which causes the full database to be sent.

Like Article
Suggest improvement
Previous
Next
Share your thoughts in the comments

Similar Reads