Open In App

Configuring EIGRP Split Horizon in Cisco

Last Updated : 13 Nov, 2022
Improve
Improve
Like Article
Like
Save
Share
Report

Pre-requisite: EIGRP fundamentals, EIGRP Configuration.

Split Horizon is a generic distance-vector protocol feature. It mandates that a route must not be advertised over an interface that was used to reach it. It helps in preventing the “re-advertising” of routing information back to the next hop from which it is learned in the first place. The logic behind the split horizon is that there is no need to advertise the cost to the destination in the upstream direction, because the cost should be higher, and the upstream routers will already have a lower-cost path available. EIGRP uses split horizon with the Poisoned Reverse which means advertising each learned network out the interface toward its successor with an infinite metric. Split Horizon with the Poisoned reverse is a powerful loop-prevention mechanism that can on occasion play havoc with the routing tables, and it sometimes becomes necessary to deactivate it, specifically in the hub and spoke networks, where multiple spoke routers are reachable over a single interface on a hub/frame relay switch. When Split Horizon is enabled with Poisoned in place, a hub learns about networks from each spoke but is forced to advertise each network as unreachable out of the same interface toward other spokes resulting in neither spoke learning about networks on other spokes.

EIGRP can be configured to deactivate the Split Horizon with Poisoned Reverse on a per-interface basis with the following command :

Device(config)#interface <interface id>
Device(config-if)#no <ip | ipv6> 
split-horizon eigrp <autonomous-system number>

Configuring EIGRP Split Horizon:

Step 1: Create the topology in Cisco Packet Tracer as shown in the image below :

  • This is a hub-and-spoke network topology with R1 serving as a hub, and R2 & R3 as spokes. All these devices are connected with each other with the help of a Frame Relay switch (FRSW1) with no changes in its configuration.
Configuring EIGRP Split Horizon

 

Step 2: Configure IPv4 address on the physical interfaces of the routers :

On R1:

interface Serial1/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
!
interface Serial1/0.123 multipoint
 ip address 192.168.123.1 255.255.255.0
 frame-relay map ip 192.168.123.2 102 broadcast
 frame-relay map ip 192.168.123.3 103 broadcast

On R2:

interface Serial1/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 no frame-relay inverse-arp
!
interface Serial1/0.123 multipoint
 ip address 192.168.123.2 255.255.255.0
 frame-relay map ip 192.168.123.1 201 broadcast

On R3:

interface Serial1/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
!
interface Serial1/0.123 multipoint
 ip address 192.168.123.3 255.255.255.0
 frame-relay map ip 192.168.123.1 301 broadcast

Step 3: Configure loop-back interfaces on routers with an IPv4 address :

On R1:

interface Loopback0
 ip address 1.1.1.1 255.255.255.0

On R2:

interface Loopback0
 ip address 2.2.2.2 255.255.255.0

On R3:

interface Loopback0
 ip address 3.3.3.3 255.255.255.0

Step 4: Configuring the EIGRP process on the routers with the command router eigrp <1-65535 Autonomous system number> :

On R1:

router eigrp 123
 network 0.0.0.0
 no auto-summary

On R2:

router eigrp 123
 network 0.0.0.0
 no auto-summary

On R3:

router eigrp 123
 network 0.0.0.0
 no auto-summary

Step 5: Checking the IPv4 routing table on the routers R1 and R2 and seeing EIGRP route entries :

show ip route
  • In R1’s routing table, there is an entry of both R1 and R2’s loop-back interface.

 

show ip route
  • In R2’s routing table, there is no entry of R3’s loopback interface which is because of the split horizon enabled on R1’s (serving as a hub in this hub-and-spoke network topology) interface Serial 1/0.123

 

  • To check whether the split horizon protocol features are enabled on R1’s interface Serial 1/0.123 with the following show command :
show ip int serial1/0.123

 

Step 6: Deactivating the Split Horizon with Poisoned Reverse on a per-interface basis on interface Serial1/0.123 multipoint :

interface Serial1/0.123 multipoint
 no ip split-horizon eigrp 123

Step 7: Checking the IPv4 routing table on R2 and seeing EIGRP route entries :

show ip route
  • In R2’s routing table, there is the entry of both R1 and R3’s loopback interface with the prefix “D” meaning EIGRP route entry.

 

Step 8 : Checking connectivity between R2 and R3’s loop back interface (Loopback0 – 3.3.3.3 /24) with R2’s loop back interface as source :

ping 3.3.3.3 source loopback 0

 


Like Article
Suggest improvement
Share your thoughts in the comments

Similar Reads