Open In App

Configuring EIGRP Timers in Cisco

Last Updated : 28 Nov, 2022
Improve
Improve
Like Article
Like
Save
Share
Report

EIGRP is an Advanced Distance Vector and Hybrid Routing Protocol. This is a CISCO proprietary protocol. It does not use broadcast packets to send information to other neighbors but will use multicast or unicast. We support multiple network layer protocols that are supported. EIGRP runs directly at the top of the IP header. EIGRP uses a rich set of metrics namely bandwidth, delay, load, and reliability which we will cover later. These values will be put into a formula and each link will be assigned a metric.

EIGRP Packets:

There are different kinds of EIGRP Packets in Routing as given below;

  1. Hello
  2. Update
  3. Query
  4. Reply
  5. ACK (Acknowledgement)

For more information, you can refer to this article: Types of EIGRP Packet in Computer Network 

Timers in EIGRP:

EIGRP timers are given below:

  1. Hello Interval
  2. Hold-time

To learn more about EIGRP timers, you can also refer to this article: EIGRP fundamentals

Commands:

Command

Description

ip hello-interval eigrp <1-65535 AS number> <1-65535 hello-time in seconds>  Configure hello-interval timer
ip hold-time eigrp <1-65535 AS number> <1-65535 hello-time in seconds>  Configure hold-down timer

Configuring EIGRP Timers:

Step 1: Create 3 router topologies in GNS3 as shown in the image below:

Configuration of EIGRP Timers

 

Step 2: Configure IPv4 address on the physical interfaces of the routers:

On R1:

interface FastEthernet0/0
 ip address 12.1.1.1 255.255.255.0
 no shutdown
interface FastEthernet1/0
 ip address 13.1.1.1 255.255.255.0
 no shutdown

On R2:

interface FastEthernet0/0
 ip address 12.1.1.2 255.255.255.0
 no shutdown

On R3:

interface FastEthernet1/0
 ip address 13.1.1.2 255.255.255.0
 no shutdown

Step 3: Configure loopback interfaces on all routers with an IPv4 address:

On R1:

interface Loopback0
 ip address 1.1.1.1 255.255.255.255

On R2:

interface Loopback0
 ip address 2.2.2.2 255.255.255.255

On R3:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255

Step 4: Configuring the EIGRP process on both routers with the command router eigrp <1-65535 Autonomous system number> :

On R1:

router eigrp 100
 network 1.1.1.1 0.0.0.0
 network 12.1.1.0 0.0.0.255
 network 13.1.1.0 0.0.0.255

On R2:

router eigrp 100
 network 2.2.2.2 0.0.0.0
 network 12.1.1.0 0.0.0.255

On R3:

router eigrp 100
 network 3.3.3.3 0.0.0.0
 network 13.1.1.0 0.0.0.255

Step 5: Configure hold-down timer of 10 seconds on all routers:

R1(config)#int range f0/0, f1/0
R1(config-if-range)#ip hold-time eigrp 100 10 
R2(config)#int f0/0
R2(config-if-range)#ip hold-time eigrp 100 10 
R3(config)#int f1/0
R3(config-if-range)#ip hold-time eigrp 100 10 

Step 6: Configure hello-interval timer of 3 seconds on R1:

R1(config)#int range f0/0, f1/0
R1(config-if-range)#ip hello-interval eigrp 100 3

Step 7: Checking the IPv4 routing table on the routers and seeing the EIGRP route entry:

R1#show ip route eigrp
ip route of router 1

 

R2#show ip route eigrp
ip route of router 2

 

R3#show ip route eigrp
ip route of router 3

 

Checking Connectivity:

Checking Connectivity from R1 to 12.1.1.0

 

Checking Connectivity from R2 to 12.1.1.0

 

Checking Connectivity from R3 to 13.1.1.0

 


Like Article
Suggest improvement
Share your thoughts in the comments

Similar Reads