Redistribution in Computer Network

Often, using a single routing protocol in an organisation is preferred but there are some conditions in which we have to use multi protocol routing. These conditions include multiple administrator running multiple protocols, company mergers or usage of multi-vendors devices. Therefore, we have to advertise a route learned through a routing protocol or by any other means (like static route or directly connected route) in different routing protocol. This process is called redistribution.

Redistribution –
It is a process of advertising a route learned by method of static routing, directly connected route or a dynamic routing protocol into another routing protocol.



For example, Here, router2 one interface (fa0/0) is running EIGRP and other interface(fa0/1) is running OSPF then we have to advertise the routes of OSPF into EIGRP and vice-versa so that the routes learned by these routing protocols are advertised with each other. This process is called redistribution. Otherwise, the router1 will not be able to learn routes of router3 and router3 will not be able to learn routes of router1.

Metric –
As we know, different routing protocols use different metrics to find out best path therefore when we redistribute route from one routing protocol to another, we have to define metric which should be understandable by the routing protocol.

For example, as we know RIP uses hop count as metric whereas EIGRP uses composite matrix which consists of Bandwidth, load, delay, reliability and MTU (from which only Bandwidth and delay are used). Therefore, when we will advertise the routes of EIGRP into RIP we have to define metric Hop count.

Example –

router(config)router rip
router(config-router)#redistribute Eigrp 1 metric 1 

Where metric 1 means hop count 1 while EIGRP 1 means autonomous system 1.

Configuration –

1. When router’s one interface is operating RIP and other interface is operating EIGRP.

Here is a small topology in which 3 routers are connected with each other. Router1 has IP address 10.1.1.1/24 on fa0/0, Router2 has IP address 10.1.1.2/24 on fa0/0 and 10.1.2.1/24 on fa0/1 and Router3 has ip address 10.1.2.1/24 on fa0/0.

Router2 has interface fa0/0 operating RIP and fa0/1 operating EIGRP and Router1 is operating RIP and Router3 is operating EIGRP as shown in the figure.
Now, configuring RIP on Router1.


Router1(config)#router rip
Router1(config-router)#network 10.1.1.0
Router1(config-router)#no auto-summary

Configuring EIGRP on Router3:

Router3(config)#router Eigrp 100
Router3(config-router)#network 10.1.2.0
Router3(config-router)#no auto-summary

Now, configuring RIP and EIGRP on Router2.

Router2(config)#router rip
Router2(config-router)#network 10.1.1.0
Router2(config-router)#no auto-summary
Router2(config-router)#exit
Router2(config)#router Eigrp 100
Router2(config-router)#network 10.1.2.0
Router2(config-router)#no auto-summary

Now, configuring redistribution on Router2, First redistributing routes of EIGRP in RIP:

Router2(config)#router rip
Router2(config-router)#redistribute eigrp 100 metric 1

Here, RIP uses metric hop count therefore we have given metric 1. Now, redistributing routes of RIP in EIGRP:

Router2(config)#router eigrp 100
Router2(config-router)#redistribute rip metric 1 0 1 1 1

Here, EIGRP uses metric composite matrix therefore, we have used k values (1 0 1 1 1).

2. When router’s one interface is operating OSPF and other interface is operating EIGRP.

Using the same topology. Router1 has IP address 10.1.1.1/24 on fa0/0, Router2 has IP address 10.1.1.2/24 on fa0/0 and 10.1.2.1/24 on fa0/1 and Router3 has ip address 10.1.2.1/24 on fa0/0.

Router2 has interface fa0/0 operating EIGRP and fa0/1 operating OSPF and Router1 is operating EIGRP and Router3 is operating OSPF as shown in the figure.
Now, configuring EIGRP on Router1.

Router1(config)#router Eigrp 100
Router1(config-router)#network 10.1.1.0
Router1(config-router)#no auto-summary

Configuring OSPF on Router3:


Router3(config)#router ospf 1
Router3(config-router)#network 10.1.2.0 0.0.0.255 area 0

Configuring EIGRP and OSPF on Router2.

Router2(config)#router eigrp 100
Router2(config-router)#network 10.1.1.0
Router2(config-router)#no auto-summary
Router2(config-router)#exit
Router2(config-router)#router ospf 1
Router2(config-router)#network 10.1.2.0 0.0.0.255 area 0

Now, redistribution on Router2:

Router2(config)#router Eigrp 100
Router2(config-router)#redistribute ospf 1 metric 1 0 1 1 1
Router2(config-router)#exit
Router2(config)#router ospf 1
Router2(config-router)#redistribute eigrp 100 subnets

3. When router’s one interface is operating EIGRP and other interface is given a static route.

Using the same topology. Router1 has IP address 10.1.1.1/24 on fa0/0, Router2 has IP address 10.1.1.2/24 on fa0/0 and 10.1.2.1/24 on fa0/1 and Router3 has ip address 10.1.2.1/24 on fa0/0.

Router2 has interface fa0/0 operating EIGRP and Router1 is operating EIGRP and Router3 is given static as shown in the figure.

Router1(config)#router eigrp 100
Router1(config-router)#network 10.1.1.0
Router1(config-router)#no auto-summary

Now, giving static route to Router3.

Router3(config)#ip route 10.1.1.0 255.255.255.0 10.1.2.2

Now, configuring EIGRP on Router2.

Router2(config)#router eigrp 100
Router2(config-router)#network 10.1.1.0
Router2(config-router)#no auto-summary

Now, redistribution on Router2

Router2(config)#router Eigrp 100
Router2(config-router)#redistribute static metric 1 0 1 1 1

Note – There is no need to give static route on Router2 as it is directly connected to 10.1.1.0 and 10.1.2.0 networks.


4. When router’s one interface is operating OSPF and other interface is given a default route

Using the same topology. Router1 has IP address 10.1.1.1/24 on fa0/0, Router2 has IP address 10.1.1.2/24 on fa0/0 and 10.1.2.1/24 on fa0/1 and Router3 has ip address 10.1.2.1/24 on fa0/0.

Router2 has interface fa0/1 operating OSPF and Router1 is given default route and Router3 is operating OSPF as shown in the figure.

Configuring default route on Router1.

Router1(config)#ip route 0.0.0.0 0.0.0.0 10.1.1.2

Configuring OSPF on Router3:

Router3(config)#router ospf 1
Router3(config-router)#network 10.1.2.0 0.0.0.255 area 0

Configuring ospf on Router2:

Router2(config)#router ospf 1
Router2(config-router)#network 10.1.2.0 0.0.0.255 area 0

Now, redistributing on Router2:

Router2(config)#router OSPF 1
Router2(config-router)#default-information originate

There are other cases also but the commands will be same as shown in the respective cases.



My Personal Notes arrow_drop_up

Check out this Author's contributed articles.

If you like GeeksforGeeks and would like to contribute, you can also write an article using contribute.geeksforgeeks.org or mail your article to contribute@geeksforgeeks.org. See your article appearing on the GeeksforGeeks main page and help other Geeks.

Please Improve this article if you find anything incorrect by clicking on the "Improve Article" button below.