Open In App

Process of Using CLI via a Telnet Session

TELNET stands for Teletype Network. It is a type of protocol that enables one computer to connect to a local computer. It is a used as a standard TCP/IP protocol for virtual terminal service which is given by ISO. Computer which starts connection known as the local computer. Computer which is being connected to i.e., which accepts the connection known as remote computer. When the connection is established between local and remote computer. Telnet is a layer 7 protocol (protocol number 23) that is used to remotely access a device. You can learn more about it here. To enable telnet on a device we must first add set up a password and also provide the line vty with a password. You can read more about passwords here.

Configuring Telnet session:

Consider a topology:



 

In this topology we are going to access the CLI of Router0 using PC0

Configuring PC0:

 

Configuring Switch0:

interface FastEthernet0/1
 switchport mode access

Configuring Router1:

interface GigabitEthernet0/0/0
 ip address 192.168.1.1 255.255.255.252
 no shutdown
interface GigabitEthernet0/0/1
 ip address 192.168.2.1 255.255.255.252
 no shutdown

Configuring Router0:

interface GigabitEthernet0/0/0
 ip address 192.168.2.2 255.255.255.252
 no shutdown

Configuring Telnet on Router0:

enable password cisco
line vty 0 4
 password cisco
 login

Configure default route on Router0:

ip route 0.0.0.0 0.0.0.0 192.168.2.1

Router0’s routing table:

show ip route

 

Now, we can access Route0’s CLI using PC0.



On PC0’s terminal execute the command:

telnet 192.168.2.2

After this you need to enter the line vty password which is Cisco in this case.

 

Now, checking the changes on Router0:

 

Article Tags :