Skip to content
Related Articles

Related Articles

Configuring RIP Versions 1 and 2 in Cisco

View Discussion
Improve Article
Save Article
  • Last Updated : 11 Jul, 2022
View Discussion
Improve Article
Save Article

Pre-requisite Routing Information Protocol (RIP)

Routing is a process of finding a path and then sending packets across networks, the device which performs these functions is called a router.

Types of Routing: 

  • Static Routing 
  • Dynamic Routing

Dynamic Routing Algorithms are based on Distance Vector or Link State routing. RIP is a Dynamic, Distance Vector Routing protocol. RIP v2 has support for classless IPs and uses multicast.

Configuration of RIP Versions 1 and 2 in Cisco:

Step 1: Open Cisco Packet Tracer ( log in if not already done so ).

Step 2: From the Network Devices category, select routers, and from the devices drag 4 2911 routers into the workspace ( we can choose any Routers, but we’re choosing 2911 for the number of ports available so that modules aren’t required )

Step 3: Select the End Devices sub-category from End Devices, and drag 3 PCs into the workspace.

Step 4: Connect all the devices using crossover cables.

Configuring RIP Versions 1 and 2 in Cisco

 

Step 5:  Assign IP addresses to PCs and Router interfaces according to the topology in the above image.

  •  For configuring a PC, Click on a PC and a window will open, select desktop and then IP configuration, and enter the required IP, subnet mask, and default gateway. An image is shown below as an example for PC0. 

 

  • For configuring Router, click on the router, in the new window select the Config tab, click on the connected interfaces, add their IPs and subnet masks, and switch on the interface. For IP assignment using CLI, navigate to the CLI tab in the Router window, and then follow commands that can be used along with IPs required on particular interfaces (like below we assign 192.168.1.1 IP to interface gig0/0. Enter no on the CLI if prompted for initial configuration.
Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface gig0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

Step 6: Now for configuring routing, first click Router 0, navigate to the CLI tab, enter no for entering initial configuration mode if prompted, and then enter the following commands on the CLI prompt to configure RIP version 1.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 192.168.1.0
Router(config-router)#network 30.0.0.0
Router(config-router)#network 20.0.0.0

For enabling RIP for a particular connected network:

network neighbour_network_ip

Step 7:  Similarly configure other routers, Router1, Router2, and Router3 according to connected networks using the above commands as a reference and using their specific neighbor network IPs in the above-mentioned syntax.

Step 8:  Test the connection by using the ping utility in the command prompt in a PC to reach another PC in other networks, the first packet might possibly not reach as it takes time for config to apply. The output might be similar to the image shown below. 

 

Step 9: The packet’s route can be seen using a simulation model as shown below. 

Simulation Results

 

 We can observe above that the packet takes the route according to the RIP metric of least hop count in the illustration above.

Now we have to check out RIP v2.

Step 1: Select the End Devices category and in the End Devices sub-category, select and drag 3 PCs as shown in the illustration below in the workspace.

Step 2: Select the Network Devices category and drag 2 2911 routes from the Router sub-category into the workspace.

Step 3: Connect all devices using crossover with the cables as shown below. 

 

Step 4: Assign IPs to PCs using the same method as described in the previous section. 

 

Step 5:  Configure Router interface IPs according to the above topology diagram using the same commands described in the previous section.

Step 6: Now for Routing using RIP v2, open the CLI in routers and enter the following commands, for Router 0.

Router>enable
Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 10.0.1.0
Router(config-router)#network 10.0.2.0
Router(config-router)#network 30.0.0.0
Router(config-router)#version 2

and similarly, configure RIPv2 on other routers using the same syntax with their directly connected networks.

Step 7: Connectivity can be confirmed by ping utility, below is an example where we ping PC2 using PC0. 

 

We can see the only difference in configuring RIPv1 and RIPv2 is the command version 2, which enables RIP version 2 in rip config mode. In terms of capabilities, RIPv2 has support for classless subnetting as its main advantage.

My Personal Notes arrow_drop_up
Recommended Articles
Page :

Start Your Coding Journey Now!