Open In App

Configuring RIP Route Summarization in Cisco

Improve
Improve
Like Article
Like
Save
Share
Report

Pre-requisites: RIP, super netting

Supernetting is mainly used in Route Summarization, where routes to multiple networks with similar network prefixes are combined into a single routing entry, with the routing entry pointing to a Super network, encompassing all the networks. This in turn significantly reduces the size of routing tables and also the size of routing updates exchanged by routing protocols. Route summarization is used to reduce the size of the routing table by creating a single entry for multiple routing entries. Route summarization helps in:

  1. Saves Bandwidth
  2. Saves memory

We are going to perform route summarization using RIP.

Step 1: Consider the Topology:

Route Summarization

 

We are going to summarize R1’s loopback addresses, but first, we need to do some configuration on the devices.

Step 3: R1’s configuration

interface FastEthernet1/0
 ip address 10.2.0.2 255.255.255.252
 no shutdown
interface Loopback1
 ip address 1.1.1.1 255.255.255.255

interface Loopback2
 ip address 1.1.1.2 255.255.255.255
interface Loopback3
 ip address 1.1.1.3 255.255.255.255
router rip
 network 0.0.0.0
 no auto-summary

Step 3: R2’s configuration

interface FastEthernet0/0
 ip address 10.1.0.2 255.255.255.252
 no sh
interface FastEthernet1/0
 ip address 10.2.0.1 255.255.255.252
 no shutdown
router rip
 network 10.2.0.0
 no auto-summary

Step 4: R3’s configuration

interface FastEthernet1/1
 ip address 10.0.0.2 255.255.255.252
 no shutdown
interface FastEthernet0/0
 ip address 10.1.0.1 255.255.255.252
 no shutdown
router rip
 network 0.0.0.0
 no auto-summary

Step 5: PC1’s configuration:

ip 10.0.0.1/30 10.0.0.2

Step 6: Now we summarize the loopback address using this command:

int f1/0
 ip summary-address rip 1.1.1.0 255.255.255.252

 Step 7: Verify whether the summary route is being propagated correctly or not. Checking R3’s routing table:

show ip route

 

Step 8: Check Connectivity. 

To check connectivity perform the following command on PC1:

 


Last Updated : 30 Nov, 2022
Like Article
Save Article
Previous
Next
Share your thoughts in the comments
Similar Reads