Open In App
Related Articles

Configuring OSPF Route Summarization in Cisco

Improve
Improve
Improve
Like Article
Like
Save Article
Save
Report issue
Report

Pre-requisites:  Open Shortest Path First (OSPF) protocol States and  Configuring Multi-Area OSPF in Cisco

Route summarization in any Interior Gateway Protocol (IGP) creates a single route entry with a prefix & prefix length larger than one or smaller component routes. For example summary route 10.1.0.0/16 includes subnets 10.1.1.0/24,10.1.4.132/30 and other subnets in the range of 10.1.0.0 to 10.1.255.255. Summary routes reduce the size of routing tables and topology databases, indirectly improving convergence. All routers in the same OSPF area must have:

  1. Identical Link State Databases after flooding is complete.
  2. Same summary routes.
  3. Must be missing the same component subnets of each summary.

To make the above thing happen, OSPF allows route summarization only if the routes are injected into an area by the following types of the router:

  1. Area Border Router (ABR)   –inter-area routes
  2. Autonomous System Boundary Router (ASBR) -external routes 

OSPF Route Summarization Commands:

Type of router

Router OSPF subcommand

ASBRsummary-address <network-id> <prefix-mask> [not-advertise]
ABRarea <area-id> range <network-id> <prefix-mask> [advertise |not-advertise]

Note: Advertise and not-advertise keywords are optional. The not-advertise keyword is used to filter the subnets implied by the summary.

Configuring OSPF Route Summarization:

Step 1: Create the 2 router topology in GNS3 as shown in the image below :

 

Step 2: Configure the IPv4 address on the physical interface on the routers :

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 10.0.0.1 255.255.255.0
R1(config-if)#no shutdown
R2(config)#interface FastEthernet0/0
R2(config-if)#ip address 10.0.0.2 255.255.255.0
R2(config-if)#no shutdown

Step 3: Configure a loopback interface on R2 with an IPv4 address :

R2(config)#interface Loopback0
R2(config-if)#ip address 8.8.8.8 255.255.255.255

Step 4: Configure loopback interfaces on R1 with IPv4 address :

R1(config)#interface Loopback0
R1(config-if)#ip address 172.168.1.1 255.255.255.0
R1(config-if)#interface Loopback1
R1(config-if)#ip address 172.168.2.1 255.255.255.0

Step 5: Configuring the OSPF process on both routers with the command router OSPF <process-id> :

R1(config)#router OSPF 1
R1(config-router)#exit
R2(config)#router OSPF 1
R2(config-router)#exit

Step 6: Enabling OSPF on the interfaces with the interface level subcommand IP OSPF <process-id> area <area-id> :

R1(config)#interface FastEthernet0/0
R1(config-if)#ip OSPF 1 area 1
R1(config-if)#interface Loopback0
R1(config-if)#ip OSPF 1 area 0
R1(config-if)#interface Loopback1
R1(config-if)#ip OSPF 1 area 0
R2(config)#interface FastEthernet0/0
R2(config-if)#ip OSPF 1 area 1
R2(config-if)#interface Loopback0
R2(config-if)#ip OSPF 1 area 1

Step 7: Checking the IPv4 routing table on the routers and seeing OSPF route entry :

R1#show ip route

 

R2#show ip route

 

Step 8: Configuring R1 (ABR) to advertise a single Inter-Area summary route that encompasses all 2 routes that are :

  1. 192.168.1.0/24
  2. 192.168.2.0/24

So, summary route 172.168.0.0/22 includes the subnet range of 172.168.0.0 – 172.168.3.255.

R1(config)#router OSPF 1 
R1(config-router)#area 0 range 172.168.0.0 255.255.252.0    
R1(config-router)#end 

Step 9:  Verifying whether the summary route is being propagated correctly or not by R1 after configuring route summarization on R1 by viewing the IPv4 routing table of R2 :

R2#show ip route

 

Step 10: Verifying the connectivity through both routers :

Now, try pinging R2’s loop-back interface from R1 and vice versa :

R1#ping 8.8.8.8

 

R1#ping 172.168.1.1

R1#ping 172.168.2.1

 


Last Updated : 04 Nov, 2022
Like Article
Save Article
Previous
Next
Share your thoughts in the comments
Similar Reads